Club Scion tC

Forum Utilities
More Transmission / Drivetrain Threads
Viewing Thread

Car wont start after installing new clutch

  • 2 posts
  • Page 1 of 1
  • 1
    • Jan 29, 2018 7:31:43 am
    Hey everyone i just installed a new clutch in my 2005 scion tc and now my car will not start. After we installed it we tried to start it and the first time it turned over and started but immediately died then we tried again and it started but i had to feather the gas for about 10 seconds and after i did that it ran for about 3 minutes and died now it will not start but it is still turning over its just like its not firing or getting fuel or something. If anyone could help i would greatly appreciate it.
    • Jan 30, 2018 7:08:14 pm
    • Edited 1 times, last by sciontc_mich on Jan 30, 2018 7:12:48pm.
    Darrellr wrote:
    Hey everyone i just installed a new clutch in my 2005 scion tc and now my car will not start. After we installed it we tried to start it and the first time it turned over and started but immediately died then we tried again and it started but i had to feather the gas for about 10 seconds and after i did that it ran for about 3 minutes and died now it will not start but it is still turning over its just like its not firing or getting fuel or something. If anyone could help i would greatly appreciate it.


    only thing I could think of is if the starter is engaging the teeth on the flywheel. but it did start and died.. hmmm.. i'm not sure other than my one thought..

    EDIT:
    ok had a thought.. check your throttle body plate/throat. I once did an oil change and when I was done, re-started the tC and same thing happened. Was coincidence and the throttle throat/plate were dirty causing the electric motor that drives the plate to stick, computer (ecu) got confused, car stalled. check that.
  • 2 posts
  • Page 1 of 1
  • 1
Jump to Forum:
Related Threads
Threads
Replies
Views
Last Post
©2018 Club Scion tC - Social Network for Scion enthusiasts.