Club Scion tC

Forum Utilities
More Tech Talk and Help Threads
Viewing Thread

2012 Scion tC k&n air filter upgrade issues

  • 2 posts
  • Page 1 of 1
  • 1
    • Mar 09, 2018 10:54:36 am
    First time here, but I recently purchased a k&n box filter for my tC. After about 5 miles the check engine light came on and was giving a p0171 (too lean in chamber 1). When I switch back to my old filter after about 5 miles the light will switch off showing the mass air sensor is working has anyone else had this issue? Could it be because the k&n's are oiled cloth instead of paper? Any help would be great.
    • Mar 10, 2018 10:56:18 pm
    • Edited 1 times, last by MR_LUV on Mar 10, 2018 10:56:40pm.
    Flyingburrito wrote:
    First time here, but I recently purchased a K&N box filter for my tC. After about 5 miles the check engine light came on and was giving a P0171 (too lean in chamber 1). When I switch back to my old filter after about 5 miles the light will switch off showing the mass air sensor is working has anyone else had this issue? Could it be because the K&N's are oiled cloth instead of paper? Any help would be great.


    Hello Flyingburrito! Welcome to CStC!

    On the surface, it does appear like the K&N's oiled cloth was causing your MAF Sensor problems.
    I myself only use OEM or in my case, I use TRD Parts and have no problems at all.


    MR_LUV


  • 2 posts
  • Page 1 of 1
  • 1
Jump to Forum:
Related Threads
Threads
Replies
Views
Last Post
©2018 Club Scion tC - Social Network for Scion enthusiasts.