Club Scion tC

Forum Utilities
More Maintenance & Repair Threads
Viewing Thread

Help!! Scion tc won't start, replaced battery

  • 3 posts
  • Page 1 of 1
  • 1
    • Oct 31, 2014 3:29:55 am
    Hello everyone my name is Scott and i'm new to this site. I tried searching the threads but I couldn't find anyone that had this exact crazy problem, so any tips or advice would greatly be appreciated.
    I own a 2005 scion tc, and while I was driving my power shut off! My center console, radio, and gauage cluster went off all at once then a few seconds later my engine and steering went out. Luckily no one was hurt and I didn't get into a accident.
    I replaced the battery and my car still won't start. The battery was tested and is fully charged. Even tried to jump start my car with the new battery and still no luck. None of my lights turn on, no radio, no gauage cluster, nothing works.
    A few months ago, my battery leak acid and it actually broke off my positive battery terminal. My brother cut and crimped a new terminal that worked perfectly fine so I don't know if maybe that could be the reason? I'm really stressed out because this is my only means on transportation. Thanks you guys for your time and reading my thread
    • Nov 06, 2014 4:34:24 pm
    Checked the fuses?
    • Nov 07, 2014 11:21:50 am
    TheFantasticG wrote:
    Checked the fuses?

    Agreed. Pull and verify visually. For some reason, the quick checkers don't work sometimes.
  • 3 posts
  • Page 1 of 1
  • 1
Jump to Forum:
Related Threads
Threads
Replies
Views
Last Post
©2018 Club Scion tC - Social Network for Scion enthusiasts.