Club Scion tC

Forum Utilities
Viewing Thread

Changed Header now throwing P0420

  • 2 posts
  • Page 1 of 1
  • 1
    • Apr 09, 2018 2:46:44 pm
    • Edited 2 times, last by theRanndom on Apr 09, 2018 2:48:17pm.

    http://i66.tinypic.com/6plvs9.jpg

    Good Evening all. I replaced my header today with the one attached and now my CEL is reading a P0420. I'm thinking I might just need the CEL eleminator to put in it. Just wondering if anyone else has any other solutions if that is not effective.
    • Apr 10, 2018 2:49:41 pm
    theRanndom wrote:
    http://i66.tinypic.com/6plvs9.jpg

    Good Evening all. I replaced my header today with the one attached and now my CEL is reading a P0420. I'm thinking I might just need the CEL eleminator to put in it. Just wondering if anyone else has any other solutions if that is not effective.


    It's because your catalytic is missing. That's why you're getting a CEL. the cat that is on the intermediate pipe is just an extra one for Toyota to meet emissions (Catches what the primary/first one does not, etc..)

    The real converter is the one that is connected right off of the stock manifold. The primary o2 sensor is actually an air/fuel ratio sensor. Putting a CEL Eliminator is a bad idea for that location, the ECU (computer) won't know if its settings are correct.

    Doesn't look like you've done any major engine mods that would call for a high flow cat like Magnaflow makes.

    Solution? seriously.. put the factory cat/exhaust manifold back on. Otherwise you're going to run into all sorts of drive-ability issues. Like you're already beginning to experience.
  • 2 posts
  • Page 1 of 1
  • 1
Jump to Forum:
Related Threads
Threads
Replies
Views
Last Post
©2018 Club Scion tC - Social Network for Scion enthusiasts.